Delayed Order Execution
Incident Report for Wealthsimple
Resolved
Database connections were restored as of 9:39 am EST. Users should now be able to access the app and resume trading activities. Thank you for your patience.
Posted Sep 16, 2019 - 09:42 EDT
Investigating
We are currently experiencing some database connection issues. Users may experience delayed execution of orders. Our team is investigating!
Posted Sep 16, 2019 - 09:38 EDT
This incident affected: Wealthsimple Trade (Login, Orders).