Limit Orders
Incident Report for Wealthsimple
Resolved
This incident has been resolved.
Posted Jun 24, 2022 - 11:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2022 - 11:35 EDT
Update
Some users may not be able to place or cancel limit orders on the Wealthsimple App. We are continuing to investigate, and we greatly appreciate your patience.
Posted Jun 24, 2022 - 11:01 EDT
Investigating
We're currently experiencing a system issue. We're investigating the issue and will provide a status update once we have more information.
Posted Jun 24, 2022 - 10:58 EDT
This incident affected: Wealthsimple Trade (Orders).