High Latency
Incident Report for Wealthsimple
Resolved
This incident has been resolved as of 12:36 pm EST. The loading and login time should now be back to normal. Thank you for your patience.
Posted Jan 21, 2020 - 12:39 EST
Investigating
We are currently experiencing some app latency issues which are preventing users from successfully logging in to and/or loading the app. Our team is investigating!
Posted Jan 21, 2020 - 10:33 EST
This incident affected: Wealthsimple Trade (Login).