High Latency
Incident Report for Wealthsimple
Resolved
This incident has been resolved as of 12:43 p.m EST, thank you for your patience!
Posted Mar 26, 2020 - 12:43 EDT
Identified
We're currently experiencing high latency on Wealthsimple Trade.

Due to this, your app may behave sluggishly and you may be experiencing longer than expected delays in order entry and updates. We're working on a fix.
Posted Mar 26, 2020 - 11:42 EDT
This incident affected: Wealthsimple Trade (Login).