Account Opening and Deposit Creation Errors
Incident Report for Wealthsimple
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 12:45 EDT
Identified
We are currently experiencing issues with some clients creating new deposits or accounts in the app. Your money is safe but recent deposits may not be available to trade until we get this fixed.
Posted Jun 18, 2021 - 12:31 EDT
This incident affected: Wealthsimple Trade (Account Setup, Funding), Wealthsimple Invest (Account Setup, Funding), and Wealthsimple Cash (Account Setup, Funding).