Market Data Deterioration
Incident Report for Wealthsimple
Resolved
The incident is now resolved as of 11:42 am EST on Feb 21, 2019. Thank you for your patience.
Posted Feb 21, 2020 - 11:58 EST
Investigating
We are experiencing some trouble retrieving data from a platform our back-office uses. This is affecting our ability to pull up-to-date information on available securities. Thank you for your patience
Posted Feb 21, 2020 - 10:38 EST
This incident affected: Wealthsimple Trade (Market Data).