High Latency
Incident Report for Wealthsimple
Resolved
The latency issue was resolved at 10:23 am on Jan 14, 2020. Users should now be able to access and load their Trade accounts without delays. Thank you for your patience.
Posted Jan 14, 2020 - 10:29 EST
Identified
We are currently experiencing some app latency issues which are preventing users from successfully logging in to and/or loading the app. Our team is investigating!
Posted Jan 14, 2020 - 10:11 EST
This incident affected: Wealthsimple Trade (Login).