Duplicate Deposit Request
Incident Report for Wealthsimple
Resolved
We've reached out to anyone affected by the duplicate deposit issue, thank you very much for your patience!
Posted Jan 09, 2020 - 20:17 EST
Identified
We are currently investigate the cause of the duplicate deposits. Please rest assured our team is working on this and we will have an update for you shortly.
Posted Jan 09, 2020 - 09:52 EST