Bad Balances
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 16:08 EDT
Update
Our developers are currently treating this as an urgent issue and are working on a resolution now but please call +1 855-255-9038 for immediate trades.
Posted Sep 10, 2020 - 14:59 EDT
Identified
We're currently experiencing an issue that may cause "available to trade" values and stock positions for some users to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted Sep 10, 2020 - 14:10 EDT
This incident affected: Trading (Order execution) and Account Values.