Bad Balances
Incident Report for Wealthsimple
Resolved
This incident has been resolved, your account values should be reporting correctly now.

Thank you very much for your patience!
Posted May 27, 2020 - 12:15 EDT
Investigating
We're currently experiencing an issue that may cause "available to trade" values and stock positions for some users to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted May 27, 2020 - 10:44 EDT
This incident affected: Wealthsimple Trade (Account).