Market Trading Halted
Incident Report for Wealthsimple Trade
Resolved
Markets have resumed trading.
Posted Mar 16, 2020 - 09:46 EDT
Identified
Due to market volatility regulations, trading has been temporarily halted. You can submit orders but will be unable to sell or buy until the exchange resumes at 9:46 a.m. EST
Posted Mar 16, 2020 - 09:34 EDT
This incident affected: Trading (Order execution).