Cash Client Agreement
Incident Report for Wealthsimple
Resolved
Most users are now on app version 2.80.0, and so we will be resolving this alert. Thank you for your understanding!
Posted Mar 09, 2023 - 10:33 EST
Investigating
Some users are reporting an issue with signing the Cash Client Agreement, where the page appears to be stuck. This can be resolved by updating to the most recent version of the app and trying again. This should not impact your ability to use the Cash service.
Posted Mar 08, 2023 - 12:24 EST
This incident affected: Wealthsimple Cash (Account Setup).