Order Submission Issues

Incident Report for Wealthsimple

Resolved

The incident has been resolved.

L'incident est maintenant résolu.
Posted Mar 17, 2025 - 12:25 EDT

Monitoring

A fix has been implemented and we're monitoring the results.

Un correctif a été mis en place et nous en assurons le suivi.
Posted Mar 17, 2025 - 12:04 EDT

Investigating

Order submission functionality is currently impacted.
Our team is investigating. Please contact our Client Success team via Chat or Phone to place immediately executable market orders.
Posted Mar 17, 2025 - 11:58 EDT
This incident affected: Investing (Trade and Orders).