Display Issues
Incident Report for
Wealthsimple
Resolved
This incident has been resolved.
Posted
Jan
23
,
2025
-
15:01
EST
Investigating
We're currently experiencing a display issue. We're working on a fix, and everything will be back to normal shortly.
Posted
Jan
23
,
2025
-
14:47
EST
This incident affected: General (Account Values).
×
Subscribe to Incident
Subscribe to updates for
Display Issues
via . You'll receive .