Market Trading Halted
Incident Report for Wealthsimple Trade
Resolved
Trading has resumed as 1:11 p.m EST.
Posted Mar 18, 2020 - 13:13 EDT
Update
Trading has resumed as 1:11 p.m EST.
Posted Mar 18, 2020 - 13:13 EDT
Identified
Due to market volatility regulations, trading has been temporarily halted. You can submit orders but will be unable to sell or buy until the exchange resumes at 1:11 p.m. EST
Posted Mar 18, 2020 - 12:56 EDT
This incident affected: Trading (Order execution).