Loading issues
Incident Report for Wealthsimple
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 18:49 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2023 - 18:47 EST
Investigating
We're currently experiencing a display issue. We're working on a fix and everything will be back to normal shortly.
Posted Feb 02, 2023 - 18:38 EST
This incident affected: Wealthsimple Trade (Login, Account Setup, Account, Funding, Orders, Market Data), Wealthsimple Invest (Login, Account Setup, Account, Funding), Wealthsimple Cash (Login, Account Setup, Account, Funding, Spend, P2P), Wealthsimple Crypto (Login, Account Setup, Account, Funding, Orders, Market Data), Wealthsimple Tax (Login, Auto-fill My Return, Filing Submission, Slips), and Phone or Chat Support.