A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 22:23 EDT
Investigating
We’re currently experiencing a system issue that is impacting app functionality. Our team is investigating.
Nous éprouvons présentement des difficultés techniques ayant un impact sur le fonctionnement de l'application.
Posted Aug 14, 2025 - 22:05 EDT
This incident affected: General (Account Login, Account Opening, Account Values, Activity Display, App or Website Display, Referrals and Promotions, Subscriptions, Website) and Investing (Alternative Investments, Crypto, Graphs, Net Deposits, Managed Investments, Trade and Orders).