Order Submission and Login Latency
Incident Report for Wealthsimple Trade
Resolved
Logins and order statuses should be operating normally again as of Oct 1, 10:37 AM EST. Thank you for your patience.
Posted 16 days ago. Oct 01, 2019 - 10:38 EDT
Investigating
We are currently experiencing high-latency with logins and navigating the Trade app. This does not affect the submission of orders themselves, but confirmations of order fulfillment and/or cancellations may be delayed. Our team is currently investigating.
Posted 16 days ago. Oct 01, 2019 - 10:21 EDT
This incident affected: Login and Account Access, Apps (iOS app, Android App), and Trading (Order submission).