Temporary delay with order statuses
Incident Report for Wealthsimple
Resolved
We've resolved the issue, and clients are now able to see accurate order statuses.
Posted May 12, 2022 - 11:27 EDT
Update
We’re still actively investigating this issue and working to restore full functionality for affected clients. We do apologize for any disruption.
Posted May 12, 2022 - 11:05 EDT
Investigating
We’re currently experiencing a temporary delay with updating order statuses to accounts. We’re working to fix this.
Posted May 12, 2022 - 09:36 EDT
This incident affected: Wealthsimple Trade (Orders).