Bad Balances
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 11:13 EST
Identified
Our team is working on implementing a fix - To correct your account balance in the meantime, please close and reopen the Trade application on your device.
Posted Jan 13, 2021 - 10:57 EST
Investigating
We're currently experiencing an issue that may cause "available to trade" values and stock positions for some users to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted Jan 13, 2021 - 10:18 EST
This incident affected: Trading (Order execution) and Account Values.