Delayed Order Status Updates
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved, thank you very much for your patience!
Posted Jun 16, 2020 - 15:11 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 16, 2020 - 15:04 EDT
Identified
We are currently experiencing delays with updating order statuses within the app. This does not affect the actual execution of the orders themselves, but confirmations of order fulfillment and/or cancellations may be delayed. Our team is investigating.
Posted Jun 16, 2020 - 14:35 EDT
This incident affected: Trading (Order status).