Trading currently unavailable
Incident Report for
Wealthsimple
Resolved
Trading has resumed for USDC.
Posted
Mar
13
,
2023
-
16:08
EDT
Investigating
Trading is temporarily unavailable for USDC due to market conditions. You can still transfer your USDC to an external wallet. Please check back later!
Posted
Mar
11
,
2023
-
09:54
EST
×
Subscribe to Incident
Subscribe to updates for
Trading currently unavailable
via . You'll receive .