Crypto trading issues | Problèmes de négociation de cryptomonnaies

Incident Report for Wealthsimple

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 10:11 EDT

Investigating

Crypto trading is unavailable. We're working on a fix.

La négociation de cryptomonnaies n'est pas disponible. Nous travaillons à résoudre le problème.
Posted Jun 25, 2026 - 09:38 EDT
This incident affected: Investing (Crypto).