Bad Balances
Incident Report for Wealthsimple
Resolved
This incident has been resolved, account values should be reflecting recent deposits correctly now.

Thank you for your patience!
Posted Jul 29, 2020 - 16:16 EDT
Monitoring
We're currently experiencing an issue that may cause any recent deposits to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted Jul 29, 2020 - 12:00 EDT
This incident affected: Wealthsimple Trade (Account).