System Issues | Difficultés techniques
Incident Report for
Wealthsimple
Update
We are continuing to monitor for any further issues.
Posted
Aug
07
,
2025
-
08:27
EDT
Monitoring
A fix has been implemented and we're monitoring the results.
Un correctif a été mis en place et nous en assurons le suivi.
Posted
Aug
07
,
2025
-
08:15
EDT
This incident affects: General (Account Login, Account Opening, Account Values, Activity Display, App or Website Display, Referrals and Promotions, Subscriptions, Website).
×
Subscribe to Incident
Subscribe to updates for
System Issues | Difficultés techniques
via . You'll receive .