Database Connections Down
Incident Report for Wealthsimple
Resolved
This incident has been resolved - thank you for your patience!
Posted Jan 14, 2021 - 11:09 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 14, 2021 - 10:54 EST
Monitoring
Orders can now be submitted through the application - there might be some latency but our team is still monitoring this.
Posted Jan 14, 2021 - 10:01 EST
Investigating
We are currently experiencing some issues that are preventing users from successfully submitting orders. Our team is investigating!

We're working to fix this. Please call +1 855-255-9038 (tel:+18552559038) for immediate trades.
Posted Jan 14, 2021 - 09:44 EST
This incident affected: Wealthsimple Trade (Login, Orders).