Balance Display Issues | Affichage de solde erroné

Incident Report for Wealthsimple

Resolved

This incident has been resolved.
Posted Dec 12, 2024 - 17:28 EST

Investigating

Certain account values may appear incorrect. Our team is investigating and working on a fix.

Certains montants de compte peuvent apparaitre inexacts. Notre équipe enquête sur la situation et travaille à une solution.
Posted Dec 12, 2024 - 02:00 EST
This incident affected: Cards and Payments (Physical Card, Virtual Card).