Wealthsimple Crypto - LUNA orders may get rejected and market order fill prices may be different than expected
Incident Report for Wealthsimple
Resolved
This incident has been resolved.
Posted May 11, 2022 - 18:35 EDT
Monitoring
LUNA is experiencing volatility. LUNA orders may get rejected and market order fill prices may be different than expected.
Posted May 11, 2022 - 11:55 EDT
This incident affected: Wealthsimple Crypto (Orders).