Delayed Order Execution
Incident Report for Wealthsimple Trade
Resolved
Database connections have been restored as of 11:51am EST. Users should be able to access the app and resume trading activities. Thank you for your patience.
Posted 4 days ago. Jun 12, 2019 - 11:53 EDT
Investigating
We are currently experiencing some database connection issues. Users may experience delayed execution of orders as well as some app connectivity issues. Our team is investigating!
Posted 4 days ago. Jun 12, 2019 - 11:46 EDT
This incident affected: Trading (Order execution), Login and Account Access, Deposits and Withdrawals, Account Values, and Apps (Android App).