Buying Power Display Issues
Incident Report for Wealthsimple
Resolved
This incident has been resolved and all balances should be reflecting correctly as of 11:43 AM EST. Thank you for your patience.
Posted Feb 13, 2020 - 13:20 EST
Identified
We're experiencing issues updating new deposits in the app. Your money is safe but it won't be available to trade until we get this fixed.
Posted Feb 13, 2020 - 10:16 EST
This incident affected: Wealthsimple Trade (Account).