Bad Balances
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved - you should be seeing the correct balances and average prices in your portfolios now. Thank you for your patience.
Posted Jan 09, 2021 - 00:00 EST
Investigating
We're currently experiencing an issue that may cause the average price and earnings of holdings for some users to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted Jan 08, 2021 - 11:43 EST
This incident affected: Trading (Order execution) and Account Values.