Order Submission Outage
Incident Report for Wealthsimple
Resolved
The incident was resolved as of 5:42 pm EST on Nov 5, 2019. All normal trading activities can be resumed. Thank you for your patience and understanding.
Posted Nov 05, 2019 - 17:57 EST
Identified
We're currently experiencing a temporary issue with submitting orders. We're working to fix this.
Posted Nov 05, 2019 - 13:04 EST