Delayed Order Execution
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 03, 2019 - 17:24 EDT
Investigating
We are currently experiencing some database connection issues. Users may experience delayed execution of orders as well as some app connectivity issues. Our team is investigating!
Posted 14 days ago. Sep 03, 2019 - 17:14 EDT
This incident affected: Login and Account Access and Trading (Order execution, Order submission).