Login Issues
Incident Report for
Wealthsimple
Resolved
This incident has been resolved.
Posted
Nov
17
,
2020
-
15:13
EST
Identified
We are currently experiencing some app connectivity issues which are preventing some users from successfully logging in to and/or loading the app.
Our team is investigating but please call +1 855-255-9038 for immediate trades.
Posted
Nov
17
,
2020
-
14:59
EST
×
Subscribe to Incident
Subscribe to updates for
Login Issues
via . You'll receive .