Bad Balances
Incident Report for Wealthsimple
Resolved
This incident has been resolved, thank you for your patience!
Posted Jun 17, 2020 - 13:38 EDT
Investigating
We're currently experiencing an issue that may cause "available to trade" values and stock positions for some users to be displayed incorrectly. This is a display issue only — your cash and stocks are safe. We're working to get this fixed as soon as possible.
Posted Jun 17, 2020 - 13:02 EDT
This incident affected: Wealthsimple Trade (Account).