Order Execution Degradation
Incident Report for Wealthsimple Trade
Resolved
Database connections have been restored as of 12:49pm EST. Users should be able to access the app and resume trading activities. Thank you for your patience.
Posted 2 months ago. May 06, 2019 - 12:50 EDT
Investigating
We are currently experiencing some issues with order execution. Our team is investigating!
Posted 2 months ago. May 06, 2019 - 12:27 EDT
This incident affected: Login and Account Access and Trading (Order execution).