Wealthsimple tax return software issues | Problèmes liés au logiciel d’Impôt

Incident Report for Wealthsimple

Resolved

The incident has been resolved.
L'incident est maintenant résolu.
Posted Apr 29, 2025 - 06:41 EDT

Monitoring

A fix has been implemented and we're monitoring the results.

Un correctif a été mis en place et nous en assurons le suivi.
Posted Apr 28, 2025 - 19:18 EDT

Investigating

You may experience problems accessing Wealthsimple tax. We’re working on a fix. In the meantime please use the direct link: http://my.wealthsimple.com/tax/2024

Vous pourriez rencontrer des difficultés pour accéder à Wealthsimple Impôt. Nous travaillons à une solution.
Posted Apr 28, 2025 - 19:05 EDT
This incident affected: Tax (Auto-fill My Return, Filing Submission, Slips).