Client cannot submit orders
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 21:45 EDT
Investigating
We are currently experiencing some issues that are preventing users from successfully submitting orders. Our team is investigating!
Posted Jun 29, 2020 - 20:06 EDT
This incident affected: Trading (Order execution, Order submission, Order status, Order Cancellation).