Order Status Degradation
Incident Report for Wealthsimple Trade
Resolved
Order status delays at were corrected at 2:05 PM EST. Thank you for your patience!
Posted Mar 13, 2020 - 14:05 EDT
Identified
We are currently experiencing delays with updating order statuses within the app. This does not affect the actual execution of the orders themselves, but confirmations of order fulfillment and/or cancellations may be delayed. Our team is investigating.
Posted Mar 13, 2020 - 14:00 EDT
This incident affected: Trading (Order status).