Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 21, 2026 - 03:30 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 16, 2026 - 09:00 EDT
Scheduled
Sending and receiving e-Transfers® will be unavailable from Sunday, June 21 from 3:30 am to 6:00 am ET. Scheduled e-Transfers® will be processed after maintenance has been completed.
L’envoi et la réception de virements Interacᴹᴰ seront temporairement indisponibles le dimanche 21 juin entre 3h30 et 6 h HAE. Les virements Interacᴹᴰ programmés seront traités dès la maintenance terminée.
Posted Jun 16, 2026 - 08:55 EDT
This scheduled maintenance affected: Money Movement (E-transfer).