Can't add new payee

Incident Report for Wealthsimple

Resolved

This incident has been resolved. Clients can now proceed with adding a new payee.
Posted Sep 25, 2023 - 22:55 EDT

Update

We are continuing to investigate this issue.
Posted Sep 25, 2023 - 22:27 EDT

Investigating

We're currently experiencing a system issue that is impacting the ability to add a new payee. We're working on a fix and everything will be back to normal shortly.
Posted Sep 25, 2023 - 21:55 EDT