Login Issues
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved.
Posted Dec 31, 2020 - 10:07 EST
Update
We are continuing to investigate this issue.
Posted Dec 31, 2020 - 10:06 EST
Investigating
We are currently experiencing some app connectivity issues which are preventing some users from successfully logging in to and/or loading the app.

Our team is investigating but please call +1 855-255-9038 for immediate trades.
Posted Dec 31, 2020 - 10:03 EST
This incident affected: Login and Account Access.