Market Trading Halted
Incident Report for Wealthsimple Trade
Resolved
Trading has resumed as of 9:50 am EST.
Posted Mar 12, 2020 - 09:51 EDT
Investigating
Due to market volatility regulations, trading has been temporarily halted. You can submit orders but will be unable to sell or buy until the exchange resumes at 9:50 a.m. EST.
Posted Mar 12, 2020 - 09:38 EDT
This incident affected: Trading (Order execution).