Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 09, 2025 - 23:00 EDT
Scheduled
Trading, withdrawing, staking, and swapping crypto will temporarily be unavailable between 11:00 pm - 11:15 pm EDT
Les opérations de négociation, de retrait, d'immobilisation (staking) et d'échange de cryptomonnaies seront temporairement indisponibles entre 23 h 00 et 23 h 15 HAE
Posted Apr 09, 2025 - 16:02 EDT
This scheduled maintenance affected: Investing (Crypto).