Account Opening Service Degradation
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved, users should be able to create new accounts without issue. Thank you for your patience.
Posted Feb 06, 2020 - 15:16 EST
Identified
We are currently experiencing issues with one of our back-office platforms. This is preventing users from creating new accounts.Our team is investigating and thank you for your patience.
Posted Feb 06, 2020 - 14:57 EST
This incident affected: Apps (iOS app, Android App).