Back Office Platform Degradation
Incident Report for Wealthsimple Trade
Resolved
The incident was resolved as of 4:02 pm EST on May 13th, 2019. All normal trading activities can be resumed as quotes are displaying correctly. Thank you for your patience.
Posted 2 months ago. May 13, 2019 - 16:03 EDT
Investigating
We are experiencing some trouble retrieving up-to-date data from a platform our back office uses. This is causing inaccurate quotes to be displayed within the app. Our team is investigating. Thank you for your patience!
Posted 2 months ago. May 13, 2019 - 15:37 EDT
This incident affected: Market Data (Quotes, Security Search) and Trading (Order execution, Order submission).