System Issues | Difficultés techniques
Incident Report for
Wealthsimple
Resolved
This has been resolved. | Ce problème a été résolu.
Posted
Aug
14
,
2025
-
21:36
EDT
Update
We are continuing to investigate this issue.
Posted
Aug
14
,
2025
-
21:28
EDT
Investigating
We’re currently experiencing a system issue that is impacting app functionality. Our team is investigating.
Nous éprouvons présentement des difficultés techniques ayant un impact sur le fonctionnement de l'application.
Posted
Aug
14
,
2025
-
21:16
EDT
This incident affected: General (Account Login, Account Opening, Account Values, Activity Display, App or Website Display, Website).
×
Subscribe to Incident
Subscribe to updates for
System Issues | Difficultés techniques
via . You'll receive .