Delayed Order Status Updates
Incident Report for Wealthsimple Trade
Resolved
This incident has been resolved and order statuses will update correctly.

Thank you very much for your patience!
Posted May 19, 2020 - 12:38 EDT
Investigating
We are currently experiencing delays with updating order statuses within the app. This does not affect the actual execution of the orders themselves, but confirmations of order fulfillment and/or cancellations may be delayed. Our team is investigating.
Posted May 19, 2020 - 12:26 EDT
This incident affected: Trading (Order status).