Account Creation Outage
Incident Report for Wealthsimple Trade
Resolved
Our team has resolved this issue, creating new accounts is now operational.
Posted 8 days ago. Oct 09, 2019 - 14:23 EDT
Identified
We are experiencing some trouble creating new accounts on Wealthsimple Trade. Users may be unable to open new accounts while our team investigates the issue. Thank you for your patience!
Posted 8 days ago. Oct 09, 2019 - 14:14 EDT
This incident affected: Login and Account Access and Apps (iOS app, Android App).