Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2023 - 05:01 EST
Scheduled
Crypto withdrawals will be unavailable Sunday, March 5th from 5:00-8:00AM EST. Deposits may see delays. All other actions will be unaffected. Sorry for the inconvenience.
Posted Mar 03, 2023 - 19:37 EST
This scheduled maintenance affected: Wealthsimple Crypto (Account, Orders).